4.2.1.3 Packet Tracer – Configuring EtherChannel




Packet Tracer – Configuring EtherChannel

Objectives

Part 1: Configure Basic Switch Settings

Part 2: Configure an EtherChannel with Cisco PAgP

Part 3: Configure an 802.3ad LACP EtherChannel

Part 4: Configure a Redundant EtherChannel Link

Background

Three switches have just been installed. There are redundant uplinks between the switches. Usually, only one of these links could be used; otherwise, a bridging loop might occur. However, using only one link utilizes only half of the available bandwidth. EtherChannel allows up to eight redundant links to be bundled together into one logical link. In this lab, you will configure Port Aggregation Protocol (PAgP), a Cisco EtherChannel protocol, and Link Aggregation Control Protocol (LACP), an IEEE 802.3ad open standard version of EtherChannel.

Part 1:     Configure Basic Switch Settings

Step 1:     Configure basic switch parameters.

a.     Assign each switch a hostname according to the topology diagram.

b.    Configure all required ports as trunks, depending on the connections between devices.

Note: If the ports are configured with dynamic auto mode, and you do not set the mode of the ports to trunk, the links do not form trunks and remain access ports. The default mode on a 2960 switch is dynamic auto.

Part 2:     Configure an EtherChannel with Cisco PAgP

Note: When configuring EtherChannels, it is recommended to shut down the physical ports being grouped on both devices before configuring them into channel groups. Otherwise, the EtherChannel Misconfig Guard may place these ports into err-disabled state. The ports and port channels can be re-enabled after EtherChannel is configured.

Step 1:     Configure Port Channel 1.

a.     The first EtherChannel created for this activity aggregates ports F0/22 and F0/21 between S1 and S3. Use the show interfaces trunk command to ensure that you have an active trunk link for those two links.

b.    On both switches, add ports F0/21 and F0/22 to Port Channel 1 with the channel-group 1 mode desirable command. The mode desirable option enables the switch to actively negotiate to form a PAgP link.

c.     Configure the logical interface to become a trunk by first entering the interface port-channel number command and then the switchport mode trunk command. Add this configuration to both switches.

Step 2:     Verify Port Channel 1 status.

a.     Issue the show etherchannel summary command to verify that EtherChannel is working on both switches. This command displays the type of EtherChannel, the ports utilized, and port states.

b.    If the EtherChannel does not come up, shut down the physical interfaces on both ends of the EtherChannel and then bring them back up again. This involves using the shutdown command on those interfaces, followed by a no shutdown command a few seconds later.

The show interfaces trunk and show spanning-tree commands also show the port channel as one logical link.

Part 3:     Configure an 802.3ad LACP EtherChannel

Step 1:     Configure Port Channel 2.

a.     In 2000, the IEEE released 802.3ad, which is an open standard version of EtherChannel. Using the previous commands, configure the link between S1 and S2 on ports G0/1 and G0/2 as an LACP EtherChannel. You must use a different port channel number on S1 than 1, because you already used that in the previous step. To configure a port channel as LACP, use the interface configuration mode channel-group number mode active command. Active mode indicates that the switch actively tries to negotiate that link as LACP, as opposed to PAgP.

Step 2:     Verify Port Channel 2 status.

a.     Use the show commands from Part 1 Step 2 to verify the status of Port Channel 2. Look for the protocol used by each port.

Part 4:     Configure a Redundant EtherChannel Link

Step 1:     Configure Port Channel 3.

There are various ways to enter the channel-group number mode command:

S2(config)# interface range f0/23 - 24

S2(config-if-range)# channel-group 3 mode ?

  active     Enable LACP unconditionally

  auto       Enable PAgP only if a PAgP device is detected

  desirable  Enable PAgP unconditionally

  on         Enable Etherchannel only

  passive    Enable LACP only if a LACP device is detected

a.     On switch S2, add ports F0/23 and F0/24 to Port Channel 3 with the channel-group 3 mode passive command. The passive option indicates that you want the switch to use LACP only if another LACP device is detected. Statically configure Port Channel 3 as a trunk interface.

b.    On switch S3, add ports F0/23 and F0/24 to Port Channel 3 with the channel-group 3 mode active command. The active option indicates that you want the switch to use LACP unconditionally. Statically configure Port Channel 3 as a trunk interface.

Step 2:     Verify Port Channel 3 status.

a.     Use the show commands from Part 1 Step 2 to verify the status of Port Channel 3. Look for the protocol used by each port.

b.    Port Channel 2 is not operative because spanning tree protocol placed some ports into blocking mode. Unfortunately, those ports were Gigabit ports. To restore these ports, configure S1 to be primary root for VLAN 1 or set the priority to 24576.


Cara Menyelesaikan :

configure S1 :

ena
conf t
hostname S1
interface range fa0/21-22
swit
switchport mode trunk
shutdown
exit
int range g0/1-2
switchport mode trunk
shutdown
exit
interface range fa0/21-22
channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1
exit
interface port-channel 1
switchport mode trunk
exit
interface range fa0/21-22
no shutdown
end
show etherchannel summary
show spanning-tree
conf t
interface range g0/1-2
channel-group 2 mode active
Creating a port-channel interface Port-channel 2
no shutdown
exit
spanning-tree vlan 1 ?
spanning-tree vlan 1 priority 24576

configure S2 :

ena
conf t
hostname S2
interface range fa0/23-24
switchport mode trunk
shutdown
exit
interface range g0/1-2
switchport mode trunk
shutdown
channel-group 2 mode active
Creating a port-channel interface Port-channel 2
no shutdown
exit
interface range fa0/23-24
channel-group 3 mode passive
Creating a port-channel interface Port-channel 3
no shutdown

configure S3 :

ena
conf t
hostname S3
interface range fa0/21-24
switchport mode trunk
shutdown
exit
interface range fa0/21-22
channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1
exit
int port-channel 1
switchport mode trunk
exit
interface range fa0/21-22
no shutdown
end
show interfaces trunk
conf t
int range fa0/21-22
no shutdown
show interfaces trunk
conf t
interface range fa0/23-24
channel-group 3 mode active
Creating a port-channel interface Port-channel 3
no shutdown